Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Marine Air Water Pump won't start
April 29, 2013
12:08 am
mrichardson364
New Member
Members
Forum Posts: 1
Member Since:
April 28, 2013
sp_UserOfflineSmall Offline

Hello All. New guy looking for some help
1989 Carver Californian
Based in Michigan City Indiana on Lake Michigan
temps in mid-60s right now. Lake temp is 40-50

Problem: water pump will not start
I have three marine air systems on board. All will start and the compressors kick in. But none will start the water pump.
I have checked the water pump by hooking it directly to 110v and it starts right up.
I have a 2-6 PRP and I moved the wiring of all three units to previously unused relay terminals. Still none started the water pump.
Note: only two of the three AC units would start the water pump last year. Today, the first day of this season none would start it.

I have found what I believe to be the wiring diagram of the Marine Air units I have. I don't see a fuse on the diagram. They seem to indicate a direct wiring to the pump or the PRP.

What am I missing? Is it the PRP? Is there a fuse before the PRP from each pump?

Should I bypass the PRP and go with a direct new circuit for the pump?

Any help would be appreciated.

Thanks
Michael