Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Marine Air VRE16K-HV - Loud Electrical Noises Between Cycles
April 6, 2012
10:11 am
tsmartt
Cumming, GA - Lake Lanier
New Member
Members
Forum Posts: 1
Member Since:
April 6, 2012
sp_UserOfflineSmall Offline

Marine Air VRE16K-HV with remote power supply and ECU digital controls. 

The system works great in heat and cool settings.  The compressor and pump is cycling at correct intervals based on thermostat setting.  The problem begins when the temperature is met during the cooling cycle and the compressor cycles off.  There is a loud noise that sounds like electrical arcing that continues until the next compressor/pump cycle.  No electrical noises occur during run cycle. The electrical noise does not occur during a heat cycle.

  I checked all visible connections for corrosion, skinned wires and bad connections but all are clean and in working order.  I have not opened the remote power box to inspect.

After further research, it appears that the noise is coming from the high pressure switch.  What is the process for replacing the switch (inline) without removing the old switch with a screw on type switch with a "T" connector?

Marine Air VRE16K-HV self contained unit with ECU digital controls that was factory installed in 1991 Sea Ray 350EC. The boat is moored at Lake Lanier north of Atlanta. Current water temp is 68. The unit is original on the boat. The EBM blower has been replaced along with the March pump.
The issue is the same whether running on shore power or generator.