Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
HPF error on Anchor Marine AC
May 29, 2012
1:00 pm
jreyn1944
Member
Members
Forum Posts: 3
Member Since:
July 12, 2011
sp_UserOfflineSmall Offline

I just replaced both of our Cal Pumps with a single Prime Time pump. IMHO, this pump is superior to the March pumps; Stainless Steel pump that can be mounted above the water line; totally enclosed non-vented splash proof motor.

Instead of acid, consider using A/C system flush from Triton Marine. It does a great job, and is totally safe to use.

February 4, 2011
8:22 am
Avatar
Steve Pooler
Admin
Forum Posts: 1127
Member Since:
November 12, 2008
sp_UserOfflineSmall Offline

Great Job finding the problem~

Intermittent or overheating pumps can be tough to find, and my first suggestion or question would have been...

When was the last time the unit's water coil was acid flushed to remove scale ?

If it's not too late...Meaning you have already bought a replacement pump...I might add that from your description it seems you are using Cal brand pumps...You may want to change brands to March...The Cal's are known to do exactly as you describe, and if you contact them about it it's been reported that they will tell you to install the pump in a bucket of water to keep it from overheating and ruining the seals...

Also...Cruisair/Marine Air quit offering Cal pumps years ago because of the high percentage of warranty returns...

 

Steve~ 

February 3, 2011
6:39 pm
sunchasers
New Member
Members
Forum Posts: 2
Member Since:
February 3, 2011
sp_UserOfflineSmall Offline

Found the problem.  My cooling pump was running but failed after 20 minutes because of overheating.  Lubricating oil was leaking from the pump.

February 3, 2011
4:02 pm
sunchasers
New Member
Members
Forum Posts: 2
Member Since:
February 3, 2011
sp_UserOfflineSmall Offline

I have an Anchor Marine model PH16-IR-D with a digital control and thermostat.  It was purchased and installed in October, 2003 and has run well since then.  It is installed on a Gulfstar Hirsh 45 sailboat located in Tavernier, FL in the Keys.  I replaced the water pump 2 years ago, and seem to be getting good water flow (same as always).  The unit will run for 20 minutes in cooling mode, then stop with an HPF error code.  The cooling tubes are hot to the touch.