Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Compressor doesn't cut off
August 18, 2011
2:42 pm
eze2bme
Member
Members
Forum Posts: 11
Member Since:
May 17, 2011
sp_UserOfflineSmall Offline

Steve

I had a used three knob control panel that I got from another Hatteras owner who had changed out his controls to the new digital controls.  I installed his three knob control panel and all is working well.  Thanks again for all your help.  By the way ... I'm still interested in the cost to convert my two - three knob control panels to digital controls ... probably this Winter.

August 16, 2011
9:42 am
Avatar
Steve Pooler
Admin
Forum Posts: 1127
Member Since:
November 12, 2008
sp_UserOfflineSmall Offline

Thanks to you too Tom...I will do that...  Cool

How did your T-Stat change out go ?

 

Steve~ 

August 15, 2011
7:02 pm
eze2bme
Member
Members
Forum Posts: 11
Member Since:
May 17, 2011
sp_UserOfflineSmall Offline

Steve

Thanks for all your help and telephone assistance.  Please email your quote to me at: ** you don't have permission to see this link **

August 15, 2011
4:15 pm
Avatar
Steve Pooler
Admin
Forum Posts: 1127
Member Since:
November 12, 2008
sp_UserOfflineSmall Offline

Yes they can...

I have spoken with Tom on the phone.

 

Steve~

August 15, 2011
12:39 pm
eze2bme
Member
Members
Forum Posts: 11
Member Since:
May 17, 2011
sp_UserOfflineSmall Offline

Steve ... my units are as follows:

Heat/AC:

      Manufacturer – Cruiseair            (16,000 btu each)

      Model No. Unit 1 – WFAH16  S/N: B98301 (Salon)

            Model No. Unit 2 – WFAH16  S/N: B98341 (Staterooms)

 

Can these units be upfitted with the digital controls and at what costs?  Thanks.

August 15, 2011
8:55 am
eze2bme
Member
Members
Forum Posts: 11
Member Since:
May 17, 2011
sp_UserOfflineSmall Offline

Steve

I have a 1979 Hatteras 43 DC; 2-16,000 BTU Cruisair units with three knob controls; 10 years ago pump wiring changed so that pump cuts ON-OFF when compressor cycles due to thermostat demand.  This past weekend on Sunday morning I awoke and found the temperature in the salon at 64 degrees (Columbia, SC).  When I turned the thermostat to a warmer setting nothing happened - compressor kept running.  I turned OFF the system and everything turned OFF.  I waited approximately 10 minutes,  turned the system back ON, and everything was running but still without responding to the thermostat.  When I turned the controls to FAN, the compressor and pump remained running.  I have noticed lately that the thermostat knob seems to be "loose" ... it sort of wobbles.  Any thoughts?  Thanks for your help!  I will look here for your comments but you may call if you want.

Tom Suber

803-546-2499