Lower Menu

Please consider registering
guest

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

   

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 3 characters - maximum search word length is 84 characters

Topic RSS
CruisAir with SMX II Panel - Temp displays 11 degrees and does not change
manteo
Member
June 1, 2011 - 1:48 pm
Member Since: May 31, 2011
Forum Posts: 4
Offline

CruisAir  with SMX II Panel – Control Panel Temp displays 11 degrees and does not change.  Since it is 85+ AC will not come on. 

 

Tried:

1) Reset to factory defaults. No change

2) Tried a spare TSE10 cable (Temp Sensing Element). No change

3) Cleaning contacts on TSE and SMX (both ends). No change. 

4) I used the calibration offset on the SMX to add 80 degrees to temperature. Now SMX display is fixed at 91 degrees. Compressor now starts and AC unit cools (displayed temprature is always 91 and does not ever change).  As expected, AC does not ever stop cooling.  

 

Is it likely that I will need to replace the the panel on the AC Unit? Will have to go back to the boat to get the actual model number for this.  Any other tests I can try?  If I need to order one, what information do you need?  Unit is about 18 years old, but works well otherwise. 

 

Any help is appreciated. 

Mike 

Steve Pooler
Admin
June 1, 2011 - 3:06 pm
Member Since: November 12, 2008
Forum Posts: 1127
Offline

Sounds like you have pretty much covered the bases except maybe to swap keypads with a known working SMXII…

There are two boards old/ large pre 1999
Or new/small post 1999….

Can have one shipped if you want to call me in the AM's
I'm usually out of the office after noon.

Steve~

manteo
Member
June 1, 2011 - 6:06 pm
Member Since: May 31, 2011
Forum Posts: 4
Offline

Steve:

Actually, I forgot to say that did try another SMX II Keypad …(this one works except the heat micro-switch no longer works so you can turn on cooling only). When I connected this keypad, same 11 degree room temperature was displayed.  

 

Tomorrow I will look at the panel that SMX II cable is connected to on the AC Unit and try to determine exactly what model  number it is.   

Thanks, 

Mike 

Steve Pooler
Admin
June 2, 2011 - 10:03 am
Member Since: November 12, 2008
Forum Posts: 1127
Offline

Mike~

I forgot to add…If your control cable is round with a flat female four prong connector on each end…You likely have the older "Large" board…

If it is a small flat cable with telephone jack type plugs on each end…Then it's likely the smaller "New" board…

Serial number of the unit can tell me when it was built…But I need model number also…

Sometimes a unit that age may have been retrofitted from 3 knob controls…If it was, there will be a separate box from the unit that will either be a A-285 or A-284 model (sticker on cover)

Units with model numbers starting with SH or SHR would be built as 3 knob units…

Units with model numbers starting with SX or SXR will be SMXII units that have the board on the unit…

 

Steve~

manteo
Member
June 2, 2011 - 8:10 pm
Member Since: May 31, 2011
Forum Posts: 4
Offline

Steve:

The AC is a SLX16 (think the L is for left hand). The connector is a older style (not phone jack style).  Guess I need the older large board.  

 

Will try to call you tomorrow morning. 

Thanks,

Mike 

Steve Pooler
Admin
June 3, 2011 - 11:06 am
Member Since: November 12, 2008
Forum Posts: 1127
Offline

Last I knew of an "L" designation for Left Hand blower was with the old Stowaway III series from back in the 80's that the blower was not easily rotatable…but that model was a BLH or BVH for Vertical…

However they did build some semi custom units for Sea Ray (and one other builder I can't recall) that would have been like SX16-L7 or something like that…

Had to do with drain locations or special seawater inlets….

 

Steve~ 

manteo
Member
December 18, 2011 - 5:25 pm
Member Since: May 31, 2011
Forum Posts: 4
Offline

Steve:

 

Problem:

CruisAir SX16 with SMX II Panel (old style) – Temp displays room temperature as 11 degrees and does not change

 

To recap, I have tried:

1) Reset to factory defaults. No change

2) Tried a spare TSE10 cable (Temp Sensing Element). No change

3) Tried an old SMX II Panel (the heat micro switch is broken, SMX but works otherwise). No change, old panel displays 11 Degrees as room temperature. 

3) Cleaning contacts on TSE and SMX II (both ends). No change. 

4) With 11 Degrees on Display, getting heat is no problem. 

5) I used the temprature calibration offset on the SMX to add 80 degrees to temperature. Now SMX display is fixed at 91 degrees. Compressor now starts and AC unit cools (displayed temprature is always 91 and does not ever change).  As expected, AC does not ever stop cooling. 

 

Unit is a SX16, Serial # A98B  (face plate has SLX16, but it is same unit except for discharge).  It is about 18 years old and works well otherwise. 

 

From you past comments, think I need the control panel. Will try to call you tomorrow. 

 

Note: I had a long absence from trying to solve this problem due to a family issue. I now have time to work on it. 

 

Thanks,

Mike 

Forum Timezone: America/New_York

Most Users Ever Online: 95

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

GeorgeH: 47

Angela: 45

z28jimi: 26

reefgeorge: 21

MexicoMike: 21

ThirdHatt: 18

davidwigler: 17

biohazard: 17

Mr. Dee: 17

mixman: 16

Ultimate Indulgence: 15

sabrejocky: 14

CaptainYAH: 14

Francois: 12

32avanti: 12

eze2bme: 11

Jack28: 11

alnmar: 11

tnsailorguy: 11

mike53c: 10

Bungay12: 10

Ed D: 10

Irwin30: 9

mbranch: 8

joesig: 7

Member Stats:

Guest Posters: 143

Members: 652

Moderators: 2

Admins: 2

Forum Stats:

Groups: 5

Forums: 11

Topics: 477

Posts: 2468

Newest Members: phillipwheat, aurelrica, dwlaking, 0Gravity, pepmyster, Hank

Moderators: Steve Pooler (1127), Michael Panaga (0)

Administrators: Steve Pooler (1127), Scott Pooler (13)